Kannel 1.5.0 fails on Debian 9

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Kannel 1.5.0 fails on Debian 9

Kasper Nielsen
Trying to install kannel_1.5.0-0_amd64.deb https://redmine.kannel.org/projects/kannel/files fails and reports the error:
kannel depends on libssl0.9.8 (>= 0.9.8m-1); however:
Package libssl0.9.8 is not installed.

However, I've got libssl1.1 installed already:
libssl-dev is already the newest version (1.1.0f-3+deb9u1).

I'm running Debian 9.
Reply | Threaded
Open this post in threaded view
|

Re: Kannel 1.5.0 fails on Debian 9

Milan P. Stanic-3
On Wed, 2018-01-24 at 10:40, Kasper Nielsen wrote:
> Trying to install kannel_1.5.0-0_amd64.deb
> https://redmine.kannel.org/projects/kannel/files fails and reports the
> error:
> kannel depends on libssl0.9.8 (>= 0.9.8m-1); however:
> Package libssl0.9.8 is not installed.

It is quite outdated
These files for then stable Debian wheezy, IIRC. I didn't posted new
version after then to the Kannel site administrator.

> However, I've got libssl1.1 installed already:
> libssl-dev is already the newest version (1.1.0f-3+deb9u1).
>
> I'm running Debian 9.

I have had build packages for newer Debian versions and hosted them on
the server behind my ADSL line, but because some auto download tools
started to download packages every day and few time which chokes ADSL,
I shut down APT repository.

But, build kannel from source is not hard so you can do that for
yourself very easy.