[ANNOUNCE] Kannel 1.4.4 stable release available

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[ANNOUNCE] Kannel 1.4.4 stable release available

Hanh Le Bich
Hello,

I have got error when do "make", please help.

app@application:/usr/src/gateway-1.4.4$ sudo make -j 24
...
gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -I/usr/local/lib/include -I/usr/include/mysql -o gw/bearerbox.o -c gw/bearerbox.c
gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -I/usr/local/lib/include -I/usr/include/mysql -o gw/smsbox.o -c gw/smsbox.c
y.tab.c:348:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wsgram.y:15:0:
./wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
wmlscript/wsgram.c:63:25: error: conflicting types for ‘ws_yy_parse’
 #define yyparse         ws_yy_parse
                         ^
y.tab.c:1508:1: note: in expansion of macro ‘yyparse’
In file included from wmlscript/wsgram.y:15:0:
./wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
wmlscript/wsgram.y: In function ‘ws_yy_parse’:
wmlscript/wsgram.y:122:23: error: ‘pctx’ undeclared (first use in this function)
   { ws_error_syntax(pctx, @1.first_line); }
                       ^
wmlscript/wsgram.y:122:23: note: each undeclared identifier is reported only once for each function it appears in
In file included from wmlscript/wslexer.c:72:0:
y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wslexer.c:70:0:
wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
In file included from wmlscript/wsstree.c:72:0:
y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wsstree.c:71:0:
wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
Makefile:231: recipe for target 'wmlscript/wsgram.o' failed
make: *** [wmlscript/wsgram.o] Error 1
make: *** Waiting for unfinished jobs....
Makefile:231: recipe for target 'wmlscript/wslexer.o' failed
make: *** [wmlscript/wslexer.o] Error 1
Makefile:231: recipe for target 'wmlscript/wsstree.o' failed
make: *** [wmlscript/wsstree.o] Error 1
app@application:/usr/src/gateway-1.4.4$


Message: 1
Date: Mon, 04 Aug 2014 15:53:42 +0200
From: Stipe Tolj <[hidden email]>
To: [hidden email], "[hidden email]" <[hidden email]>,
        kannel users <[hidden email]>
Subject: [ANNOUNCE] Kannel 1.4.4 stable release available
Message-ID: <[hidden email]>
Content-Type: text/plain; charset="iso-8859-15"; Format="flowed"

The Kannel Group is pleased to announce the availability of Kannel 1.4.4
stable release via our web site at URL

    http://www.kannel.org/download.shtml

Please find attached the NEWS file section for the 1.4.4 stable release.

Best Regards,
Stipe Tolj

--
-------------------------------------------------------------------
K?lner Landstrasse 419
40589 D?sseldorf, NRW, Germany

tolj.org system architecture      Kannel Software Foundation (KSF)
http://www.tolj.org/              http://www.kannel.org/

mailto:[hidden email]           mailto:[hidden email]
-------------------------------------------------------------------

Regards,
Hanh.
Reply | Threaded
Open this post in threaded view
|

Re: [ANNOUNCE] Kannel 1.4.4 stable release available

Stipe Tolj-2
Am 08.08.2014 11:30, schrieb Hanh Le Bich:

> Hello,
>
> I have got error when do "make", please help.
>
> app@application:/usr/src/gateway-1.4.4$ sudo make -j 24
> ...
> gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600
> -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2
> -I/usr/local/lib/include -I/usr/include/mysql -o gw/bearerbox.o -c
> gw/bearerbox.c
> gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600
> -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2
> -I/usr/local/lib/include -I/usr/include/mysql -o gw/smsbox.o -c gw/smsbox.c
> y.tab.c:348:5: error: conflicting types for ‘ws_yy_parse’
> In file included from wmlscript/wsgram.y:15:0:
> ./wmlscript/wsint.h:296:5: note: previous declaration of
> ‘ws_yy_parse’ was here
>   int ws_yy_parse(void *context);
>       ^
> wmlscript/wsgram.c:63:25: error: conflicting types for ‘ws_yy_parse’
>   #define yyparse         ws_yy_parse
>                           ^
> y.tab.c:1508:1: note: in expansion of macro ‘yyparse’
> In file included from wmlscript/wsgram.y:15:0:
> ./wmlscript/wsint.h:296:5: note: previous declaration of
> ‘ws_yy_parse’ was here
>   int ws_yy_parse(void *context);
>       ^
> wmlscript/wsgram.y: In function ‘ws_yy_parse’:
> wmlscript/wsgram.y:122:23: error: ‘pctx’ undeclared (first use in
> this function)
>     { ws_error_syntax(pctx, @1.first_line); }
>                         ^
> wmlscript/wsgram.y:122:23: note: each undeclared identifier is reported
> only once for each function it appears in
> In file included from wmlscript/wslexer.c:72:0:
> y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
> In file included from wmlscript/wslexer.c:70:0:
> wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’
> was here
>   int ws_yy_parse(void *context);
>       ^
> In file included from wmlscript/wsstree.c:72:0:
> y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
> In file included from wmlscript/wsstree.c:71:0:
> wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’
> was here
>   int ws_yy_parse(void *context);
>       ^
> Makefile:231: recipe for target 'wmlscript/wsgram.o' failed
> make: *** [wmlscript/wsgram.o] Error 1
> make: *** Waiting for unfinished jobs....
> Makefile:231: recipe for target 'wmlscript/wslexer.o' failed
> make: *** [wmlscript/wslexer.o] Error 1
> Makefile:231: recipe for target 'wmlscript/wsstree.o' failed
> make: *** [wmlscript/wsstree.o] Error 1
> app@application:/usr/src/gateway-1.4.4$

most likely there is an issue with the yacc parser on your system. Do
you have the 'bison' package installed?

The files that are referenced here are "generated" during the initial
make run. Please try to re-create the files from the package itself and
then re-compile.

If that does not help, please indicate the issue via our bug tracking
system (see website) and report with architecture and Linux distro you
are using.

Stipe

--
-------------------------------------------------------------------
Kölner Landstrasse 419
40589 Düsseldorf, NRW, Germany

Kannel Foundation                 tolj.org system architecture
http://www.kannel.org/            http://www.tolj.org/

mailto:stolj_{at}_kannel.org      mailto:st_{at}_tolj.org
-------------------------------------------------------------------

Reply | Threaded
Open this post in threaded view
|

Re: [ANNOUNCE] Kannel 1.4.4 stable release available

Hanh Le Bich
In reply to this post by Hanh Le Bich
Many thanks Stipe.
I've created new issue in the bug report. It's weird that have never got this with SVN versions.
Anyway, i've been successful to compile on another machine with bison version 2.5 (the fail one has bison version 3.0.2), remain resource are same, because they are 2 VM on a same physical server, also OS.

Regards,
Hanh.


On Fri, Aug 8, 2014 at 4:30 PM, Hanh Le Bich <[hidden email]> wrote:
Hello,

I have got error when do "make", please help.

app@application:/usr/src/gateway-1.4.4$ sudo make -j 24
...
gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -I/usr/local/lib/include -I/usr/include/mysql -o gw/bearerbox.o -c gw/bearerbox.c
gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -I/usr/local/lib/include -I/usr/include/mysql -o gw/smsbox.o -c gw/smsbox.c
y.tab.c:348:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wsgram.y:15:0:
./wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
wmlscript/wsgram.c:63:25: error: conflicting types for ‘ws_yy_parse’
 #define yyparse         ws_yy_parse
                         ^
y.tab.c:1508:1: note: in expansion of macro ‘yyparse’
In file included from wmlscript/wsgram.y:15:0:
./wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
wmlscript/wsgram.y: In function ‘ws_yy_parse’:
wmlscript/wsgram.y:122:23: error: ‘pctx’ undeclared (first use in this function)
   { ws_error_syntax(pctx, @1.first_line); }
                       ^
wmlscript/wsgram.y:122:23: note: each undeclared identifier is reported only once for each function it appears in
In file included from wmlscript/wslexer.c:72:0:
y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wslexer.c:70:0:
wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
In file included from wmlscript/wsstree.c:72:0:
y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wsstree.c:71:0:
wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
Makefile:231: recipe for target 'wmlscript/wsgram.o' failed
make: *** [wmlscript/wsgram.o] Error 1
make: *** Waiting for unfinished jobs....
Makefile:231: recipe for target 'wmlscript/wslexer.o' failed
make: *** [wmlscript/wslexer.o] Error 1
Makefile:231: recipe for target 'wmlscript/wsstree.o' failed
make: *** [wmlscript/wsstree.o] Error 1
app@application:/usr/src/gateway-1.4.4$


Message: 1
Date: Mon, 04 Aug 2014 15:53:42 +0200
From: Stipe Tolj <[hidden email]>
To: [hidden email], "[hidden email]" <[hidden email]>,
        kannel users <[hidden email]>
Subject: [ANNOUNCE] Kannel 1.4.4 stable release available
Message-ID: <[hidden email]>
Content-Type: text/plain; charset="iso-8859-15"; Format="flowed"

The Kannel Group is pleased to announce the availability of Kannel 1.4.4
stable release via our web site at URL

    http://www.kannel.org/download.shtml

Please find attached the NEWS file section for the 1.4.4 stable release.

Best Regards,
Stipe Tolj

--
-------------------------------------------------------------------
K?lner Landstrasse 419
40589 D?sseldorf, NRW, Germany

tolj.org system architecture      Kannel Software Foundation (KSF)
http://www.tolj.org/              http://www.kannel.org/

mailto:[hidden email]           mailto:[hidden email]
-------------------------------------------------------------------

Regards,
Hanh.

Reply | Threaded
Open this post in threaded view
|

Re: [ANNOUNCE] Kannel 1.4.4 stable release available

DHC Admin
i have fixed the same problem by installing all the needed packages, deleting the gateway-1.4.4 and starting the whole thing from scratch, re running ./configure is not enough, so it looks.
At first I was lacking byacc and bison
Regards


On Fri, Aug 8, 2014 at 7:44 AM, Hanh Le Bich <[hidden email]> wrote:
Many thanks Stipe.
I've created new issue in the bug report. It's weird that have never got this with SVN versions.
Anyway, i've been successful to compile on another machine with bison version 2.5 (the fail one has bison version 3.0.2), remain resource are same, because they are 2 VM on a same physical server, also OS.

Regards,
Hanh.


On Fri, Aug 8, 2014 at 4:30 PM, Hanh Le Bich <[hidden email]> wrote:
Hello,

I have got error when do "make", please help.

app@application:/usr/src/gateway-1.4.4$ sudo make -j 24
...
gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -I/usr/local/lib/include -I/usr/include/mysql -o gw/bearerbox.o -c gw/bearerbox.c
gcc -std=gnu99 -D_REENTRANT=1 -I. -Igw -g -O2 -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_LARGE_FILES= -I/usr/include/libxml2 -I/usr/local/lib/include -I/usr/include/mysql -o gw/smsbox.o -c gw/smsbox.c
y.tab.c:348:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wsgram.y:15:0:
./wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
wmlscript/wsgram.c:63:25: error: conflicting types for ‘ws_yy_parse’
 #define yyparse         ws_yy_parse
                         ^
y.tab.c:1508:1: note: in expansion of macro ‘yyparse’
In file included from wmlscript/wsgram.y:15:0:
./wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
wmlscript/wsgram.y: In function ‘ws_yy_parse’:
wmlscript/wsgram.y:122:23: error: ‘pctx’ undeclared (first use in this function)
   { ws_error_syntax(pctx, @1.first_line); }
                       ^
wmlscript/wsgram.y:122:23: note: each undeclared identifier is reported only once for each function it appears in
In file included from wmlscript/wslexer.c:72:0:
y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wslexer.c:70:0:
wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
In file included from wmlscript/wsstree.c:72:0:
y.tab.h:262:5: error: conflicting types for ‘ws_yy_parse’
In file included from wmlscript/wsstree.c:71:0:
wmlscript/wsint.h:296:5: note: previous declaration of ‘ws_yy_parse’ was here
 int ws_yy_parse(void *context);
     ^
Makefile:231: recipe for target 'wmlscript/wsgram.o' failed
make: *** [wmlscript/wsgram.o] Error 1
make: *** Waiting for unfinished jobs....
Makefile:231: recipe for target 'wmlscript/wslexer.o' failed
make: *** [wmlscript/wslexer.o] Error 1
Makefile:231: recipe for target 'wmlscript/wsstree.o' failed
make: *** [wmlscript/wsstree.o] Error 1
app@application:/usr/src/gateway-1.4.4$


Message: 1
Date: Mon, 04 Aug 2014 15:53:42 +0200
From: Stipe Tolj <[hidden email]>
To: [hidden email], "[hidden email]" <[hidden email]>,
        kannel users <[hidden email]>
Subject: [ANNOUNCE] Kannel 1.4.4 stable release available
Message-ID: <[hidden email]>
Content-Type: text/plain; charset="iso-8859-15"; Format="flowed"

The Kannel Group is pleased to announce the availability of Kannel 1.4.4
stable release via our web site at URL

    http://www.kannel.org/download.shtml

Please find attached the NEWS file section for the 1.4.4 stable release.

Best Regards,
Stipe Tolj

--
-------------------------------------------------------------------
K?lner Landstrasse 419
40589 D?sseldorf, NRW, Germany

tolj.org system architecture      Kannel Software Foundation (KSF)
http://www.tolj.org/              http://www.kannel.org/

mailto:[hidden email]           mailto:[hidden email]
-------------------------------------------------------------------

Regards,
Hanh.


Reply | Threaded
Open this post in threaded view
|

Re: [ANNOUNCE] Kannel 1.4.4 stable release available

Stipe Tolj-2
Am 27.08.2014 17:39, schrieb DHC Admin:
> i have fixed the same problem by installing all the needed packages,
> deleting the gateway-1.4.4 and starting the whole thing from scratch, re
> running ./configure is not enough, so it looks.
> At first I was lacking byacc and bison
> Regards

thanks a lot for reporting. We assumed it's simply the missing 'bison'
and the way the pre-installed yacc does the compilation that messes up
the build.

Stipe

--
-------------------------------------------------------------------
Kölner Landstrasse 419
40589 Düsseldorf, NRW, Germany

Kannel Foundation                 tolj.org system architecture
http://www.kannel.org/            http://www.tolj.org/

mailto:stolj_{at}_kannel.org      mailto:st_{at}_tolj.org
-------------------------------------------------------------------

Reply | Threaded
Open this post in threaded view
|

Re: [ANNOUNCE] Kannel 1.4.4 stable release available

Wayne Gemmell-2
Hi

The compile works with bison 2.5 but not with 3.0.4 so I can install with Ubuntu Precise but not Ubuntu Trusty.
I've managed to install bison 2.5 onto Trusty and compete the installation. I've located the bug that was created about this https://redmine.kannel.org/issues/699 but there are no responses as yet. 

On Wed, Aug 27, 2014 at 11:57 PM, Stipe Tolj <[hidden email]> wrote:
Am <a href="tel:27.08.2014%2017" value="+12708201417" target="_blank">27.08.2014 17:39, schrieb DHC Admin:
i have fixed the same problem by installing all the needed packages,
deleting the gateway-1.4.4 and starting the whole thing from scratch, re
running ./configure is not enough, so it looks.
At first I was lacking byacc and bison
Regards

thanks a lot for reporting. We assumed it's simply the missing 'bison' and the way the pre-installed yacc does the compilation that messes up the build.


Stipe

--
-------------------------------------------------------------------
Kölner Landstrasse 419
40589 Düsseldorf, NRW, Germany

Kannel Foundation                 tolj.org system architecture
http://www.kannel.org/            http://www.tolj.org/

mailto:[hidden email]      mailto:[hidden email]
-------------------------------------------------------------------